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SmartTimer Evaluation 
Ready-Start Guide 

 
 
This guide is to provide a quick start guide to the SmartTimer Timer Client program.  
Additionally, it contains a 15 page excerpt from the main SmartTimer Configuration Guide for configuring the Advanced Security 
Options. 
The full manual is only available to those customers who purchase the SmartTimer Client. 
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IMPORTANT INFORMATION 
This only applies to the Evaluation 

Version of the SmartTimer Client, and 
cannot be changed. 

 
However, if you purchase the 

SmartTimer System, you will be given 
new information which you should write 

down in a spot like this inside the 
SmartTimer Configuration Guide. 

 
Your Access Code is 

 

___SMART3191__ 
 (Please note the Access Code is Case Sensitive) 

 
SERVER IP ADDRESS 

 

__203.46.120.40__ 
 

PORT NUMBER 
 

_________8000________ 
 

OPERATOR ID  LOCATION ID 
 

_____1_____  _____1_____ 
 

Multiple Location Information 
(Optional) 

  ID      Location Name   
 

Not applicable 
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SmartTimer Quick Start Guide 

Instructions for Smarttimer Client V2.5 Setup and Install 
1. Take the executable file from the web site, email, or CD that has been sent to you, and place it on each computers hard disk 

drive. 

(If you have already previously installed a older version of the SmartTimer Client, please make sure you remove it prior to 

installing the new version). 

2. Run the executable from the hard disk drive. 

3. Click ‘Next >’ to continue the install 

4. By default it will want to install the Smarttimer Client in a directory called  

‘C:\Program Files\Smartware’ 

Here you can increase security by changing the default install directory, by inserting your own, preferably under the 

windows directory ie. 

c:\windows\manage 

c:\windows\auxtools 

5. Click ‘Next >’ to continue the install. 

6. It will then ask you to restart your computer. 

7. Using My Computer, or Windows Explorer, locate the file Client.exe located in the program directory where you installed 

the Smarttimer Client. 

8. Run the program Client.exe 
9. SmartTimer Client is now installed and running. 
10. Next you will have to configure Security, and other confidential settings appropriate to the Smarttimer Client and your 

particular settings. 
 

Smarttimer Security 

1. Please type in the security code provided to you for your own security access. 
(Please note, each client receives a different custom build of the code which has their own access code embedded into the client. No 
other access code will function apart from Smartware’s, yours, and any particular code you set in the security). 

2. Click on the Button ‘Configure Security’ 
A. Click on the Tab Basic Security Measures 
B. If not checked, check ‘Automatically Run SmartTimer Client on Login’ 
C. If not checked, check ‘Automatically Log Out CTRL-ALT-DEL’ 
D. If not checked, check ‘Stop Open Programs on Exit’ 
E. Type in the Default Resolution you want your monitor to be set to. 
F. Type in the Default Web Page you want Internet Explorer to by continuously set to. 
G. If you want the SmartTimer Client to act as a pseudo screen saver using the embedded web page as a screen saver (using 

such tags as the meta-refresh tag to rotate screens much like a screen saver here), put in your delay in minutes, if you do not 
want a pseudo screen saver then place a 0 in the minutes box. 

H. Click the Save Changes Button 
I. Click the Save Config Changes Button 

3. Click on the Button ‘Configure Client’ 
This section allows you to configure the overall appearance of the smarttimer client interface, from colours to individual fonts. 
Notes: 
When putting in colours, you can used the same colour format as web pages, and it will be automatically converted to the correct 
colour numbers used by the SmartTimer Client program. 
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When setting the Scrolling Banners Multiple Line Feature, you need to press SHIFT-RETURN to put a new line in, and a blank line 
should be included at the end of the banner. 
The Float on Top of other Programs option should not be checked until very last, otherwise it may make things difficult in selecting 
some configuration options. 
Click the Save Config Changes Button once you are happy with the changes made to the configuration. 

4. Click on the Button ‘System Settings’ 
This section allows you to adjust the system settings to connect to the SmartTimer Server, Validation Options, and Additional 
Password Protection. 
 
Click on the Password Protection Tab 
Here you can set your own private password for your staff to use. To set, type in the password you want to use twice, and the Master 
Override Code that we have provided to you. Once these have been typed in, press the Set Local Password Button to set the password. 
This password has all the same privileges as the one we gave you, but not the ability to adjust any passwords. 
 
Click on the Edit System Properties Tab 
These settings should have already been filled out by us, in our pre-configuration for you. Though you should check these off against 
the confirmation email we send you to ensure all settings are correct. 
Time Out should be set to between 10-20 seconds. 
Validate PIN before Starting the Time System should be left checked. 

5. Click on the Button ‘Advanced Security’ 
This section does rely on editing the system registry, and needs administrator rights to apply. So the client should be installed under 
administrator privileges, security set, then administrator privileges revoked under windows 2000. 
To simplify the advanced security options, click on the button One Touch Setup to apply basic security features, and One Touch 
Remove to remove the basic security features. Once basic measures have been applied, using the other 8 categories, you can then 
customize your security needs to match your own circumstances. 
To assist you, the rest of this manual contains the Advanced Security extract from the main SmartTimer Configuration Guide. It is 
recommended that you read this extract before you decide to play around with any of the advanced security options. 

6. Reboot the Computer 
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Advanced Security 

 
The Advanced Security section can only be worked with while the program has rights to access the system 
registry. This means the program needs to be running with administrator privileges for the changes made here 
to apply. 
Also note: Each setting is applied immediately, and while some settings will take immediate effect, a reboot 
may be in order for other elements to be affected. 

One Touch Setup 

One Touch Remove 
These two buttons apply and remove the basic common security protocols for the SmartTimer Client.  
It is recommended that you start with the One Touch protocols, unless you wish to customise your security 
protocols (these One Touch protocols are accessed through the One Touch Setup and One touch Remove 
Buttons). 
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Start Menu 
 
These protocols affect the struct ure and layout 
of the Start Menu and Taskbar in Windows 98, 
Me, 2000 and XP. 
 
Classic Start Menu (Windows XP) 
Forces the use of the Windows 98/2000 layout 
instead of the XP layout 
 
Hide Favourites 
Hides the Favourites folder in the Start Menu 
 
Hide Documents 
Hides the Documents Folder in the Start Menu. 
 
Remove My Documents, Remove My Pictures, Remove My Music 
Clicking these will remove these sub folders from the Documents folder in the Start Menu 
 
Do Not Save Recent Documents 
Clicking this will cause the OS not to update the Recent Documents section of the Documents Folder with the 
latest files/pages opened. 
 
Clear Recent Documents at Log off 
This will cause the recent documents section to be blanked when a windows log off/reboot command is 
generated. 
 
Hide Settings 
This causes the Settings section to be hidden in the Start Menu 
 
Remove Network Connections 
This removes the Network Connections folder from the Settings Menu 
 
Hide Find, Hide Run, Hide Shutdown, No Help, Hide Log Off 
These remove the appropriate commands from the Start Menu 
 
Hide Common Groups 
Removes the Common Groups folders from the Start Menu (these are program folders that are visible to all 
users). 
 
Hide Instrumentation 
This setting stops Windows from recording user tracking information including which applications a user runs 
and which files and documents are being accessed. 
 
No Network Places 
Removes the Network Places from the System 
 
No Drag and Drop 
Denies the ability to drag and drop items onto the task bar. 
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Hide Admin Tools 
This hides the admin tools on the Start Menu 
 
Hide Setting in Taskbar 
Prevents you accessing Taskbar settings 
 
No Toolbars on Taskbar 
Removes any toolbars on the Taskbar 
 
Lock the Taskbar 
Prevent changes to the Task Bar 
 
No Clock on Taskbar 
Remove the Taskbar Clock 
 
No Tray Items on Taskbar 
Removes any tray items from the Taskbar 
 
Hide Administrative Tools 
This hides the admin tools on the Start Menu 
 
Win Security (Terminal Services) 
This setting is used to hide the Windows NT Security menu item on the Start Menu of a terminal server session. 
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Control Panel 
 
Old Style Control Panel (XP) 
Forces the use of the 2000 style control panel in 
Windows XP. 
 
Hide Control Panel in Explorer 
Removes the control panel from explorer. 
 
Restrict the Display Panel 
Deny access to the Display Settings Control 
Panel. 
 
Hide Background, Screensaver 
Appearance, Setting, and Active 
Desktop Pages. 
Removes the appropriate pages from the Display Settings Control Panel. 
 
Hide Device Manager Page 
Restricts access to the Device Manager in Computer Properties. 
 
Hide Hardware Profiles 
Remove the Hardware Profiles page in Computer Properties 
 
Hide File System Button, Hide Virtual Memory Button 
Removes the appropriate buttons from the Computer Properties section. 
 
Disable Password Control Panel 
Restrict access to the Password Control Panel 
 
Hide Profile, Admin and Change Password Pages 
Hides the Profile, Admin and Change Password Pages in the Password Control Panel 
 
Disable Network Access Control 
Disable access to the Network Configuration pages. 
 
Hide Net Setup ID Page, Hide Printer and File Sharing 
Selecting these will disable the respective pages within the Network Access Control Panel 
 
Hide Network Access Control 
Hide the Network Access Control Panel 
 
Hide Set Program Access 
This restriction is used to hide "Set Program Access and Defaults" on the Add or Remove Programs page. 
 
Hide Add/Remove Program Restrictions 
These restrictions apply to the Add/Remove Programs feature of Control Panel. They allow you to entirely or 
individually disable components.  
NoAddRemovePrograms - Disable Add/Remove Programs  
NoRemovePage - Disable Change and Remove Programs  



  Page 9 

SmartTimer Evaluation Ready-Start Guide  ©2004 Smartware Corporation 

NoAddPage - Disable Add Programs  
NoWindowsSetupPage - Disable Windows Components Wizard  
NoAddFromCDorFloppy - Hide "Add a program from CD-ROM or disk" option  
NoAddFromInternet - Hide "Add programs from Microsoft" option  
NoAddFromNetwork - Hide "Add programs from your network" option  
NoServices - Go directly to Windows Components Wizard  
NoSupportInfo - Disable Support Information  
 
Hide File and Screen Sharing Controls 
Enabling this options hides the file and printer sharing controls, stopping users from disabling or creating new 
file or printer shares 
 
Disable Add Printers, Disable Delete Printers 
Removes the ability to Add or Delete printers. 
 
Disable Printer General Pages 
Removes the ability to see the general page in Printer Properties 
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Desktop 
Disable Active Desktop 
Turns off the Active Desktop 
 
Hide My Computer 
Hides the My Computer Icon on the Desktop 
 
Hide Properties in My Computer 
Hides the Properties for the My Computer Icon 
 
Hide My Documents, Hide Recycle Bin 
Hides the My Documents, or Recycle Bin Icons on the Desktop 
 
Hide All Items on Desktop 
Hide all icons, and material on the desktop 
 
Hide Network Neighbourhood 
Hide the Network Neighbourhood Icon on the Desktop 
 
Hide Workgroup 
Hide the Workgroup Icon within Network Neighbourhood 
 
Don’t Save Settings on Logout 
Do not save any settings when Logging out of Windows 
 
Disable Screen Saver 
Turn off any screen saver 
 
No Right Click on Desktop 
Disable the ability to right click on the desktop 
 
No ability to customise Toolbars 
Deny the ability to customise explorer toolbars 
 
No ability to change or hide Toolbars 
Deny the ability to change or hide toolbars in explorer 
 
Remove File Menu from Explorer 
Removes the File Menu item from Explorer 
 
Disable Folder Options 
Removes the ability to select Folder Options from the Tools Menu 
 
Disable Ability to Modify File Types 
Removes the ability to modify file types and Associations
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System 
Disable Registry Editing Tools 
Stops people using the Regedit tools provided 
with Windows 
 
Disable Win Old Apps, No Real Mode 
MS-DOS Apps 
Turns off DOS programs run from the command 
prompt 
 
Disable Task Manager 
Turns off Task Manager in 2000 and XP when 
you press CTRL-ALT-DEL 
 
Disable Lock Workstation 
Turns off Lock Workstation in 2000 and XP when you press CTRL-ALT-DEL 
 
Disable Change Password 
Turns off Change Password in 2000 and XP when you press CTRL-ALT-DEL 
 
Hide ‘C’ in Explorer 
Hide C Drive from Explorer so a customer cannot see it. 
 
Disable Tray Context menus 
This setting removes the context menus (right click on the taskbar) for the system tray, including the Start 
button, Tab control, and Clock. 
 
Disable Moving Bands 
This setting disables tool bar customisation. 
 
Disable Customise bands 
By default users are able to select which toolbars are displayed either be right clicking the toolbar itself, or by 
changing the options from the View menu. This tweak locks the toolbars, removing the ability to change which 
are displayed. 
 
 
Disable Low Disk Space Checks 
Turns off low disk space notification 
 
Disable Internal CD Burning (XP) 
Stops XP native CD Writing if a burner is installed 
 
No Win Keys 
Disable Win Keys 
 
No Windows Update 
Remove the Windows Update Option 
 
No Save Setting 
Do not save any setting changes 
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Hide Drives and Restrict Drive Access 
Hide and/or Restrict Access to the selected drive letters 
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Internet Explorer 
 
No Password Caching 
Remove the ability to save passwords 
 
No Right Clicking/Context Menus 
Remove the ability to right click on the web 
page 
 
No Browser Options 
Removes Internet Options from the Tools 
Menu 
 
No Browser Save As 
Remove Save As from the File Menu 
 
No Favourites 
Removes the Favourites Icon 
 
No File -> Open 
Remove the Open command from the File Menu 
 
No Find Files 
Removes the ability to find files from the File Menu 
 
No Select Download Directory 
Prevents people changing the default download directory 
 
No Full Screen/Theatre Mode 
Prevents people from setting the browser to full screen mode 
 
No Toolbar, No Toolbar Options 
Prevents people customising the Toolbar or removes the ability to get the Toolbar options 
 
No Links Bar 
Removes the Links Bar 
 
No View Source 
Removes the ability to view the source HTML of  web page 
 
No Navigation Buttons 
Removes the Navigation Buttons from the browser 
 
No File - > Print 
Prevents printing from the browser 
 
No Browser Bars 
Disables changes made to IE toolbars. 
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Always prompt when downloading 
Always ask to confirm before downloading 
 
No Mail and News Menu Items 
Remove the mail and news menu items from the browser 
 
No Browser Close 
Removes the Close/Exit option from the browser 
 
No File -> New 
Removes the New browser instance from the browsers file menu 
 
No Address Bar 
Removes the Address Bar from the browser 
 
No Help Menu, No IE/Netscape Help, No Feedback 
Removes the appropriate help options from the menu 
 
No Tip of the Day, No Tour/Tutorial 
Removes the Tip of the Day, and the Tour options from the menu 
 
No Expanded New 
Removes the sub menu that appears when you click on File | New 
 
No Go Button 
Removes the Go Button from the toolbar 
 
No Auto Complete 
Forces the user to type in a full URL, there is no auto completion 
 
No File URL’s 
Removes the ability to open a local file in the browser 
 
No IE 6 Error Reporting 
Removes any IE 6 bug reports if there is an error in the browser 
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IE Control Panel 
 
Hide General Tab 
This Hides the General Tab in Internet 
Options. 
 
The Following commands all affect 
individual pages and elements within the 
General Tab. 
 
Disable Home Page Buttons 
Disable Cache Settings Button 
Disable Cache Settings Dialog 
Disable History Buttons 
Disable Colours Setting 
Disable Languages Tab 
Disable Links Setting 
Disable Fonts Dialog 
Disable Languages Dialog 
 
Hide Content Tab 
This hides the Content tab in the Internet Explorer Control Panel 
The Following commands all affect individual pages and elements within the Content Tab. 
 
Disable Rating 
Disable Certificates 
Disable Certif Pers 
Disable Certificate Publishers 
Disable Certificate Site 
Disable Form Suggest 
Disable Form Suggest Passwords 
Disable Profile Buttons 
 
Hide Connections 
This option allows you to hide the Connections Tab in the IE Control Panel 
The Following commands all affect individual pages and elements within the Connections Tab. 
 
Disable Connection Wizard 
Turns off the Internet Connection Wizard/Dialler configuration 
 
Disable Connection Settings 
Turns off the ability to adjust the connection settings (i.e. selecting dial up connections) 
 
Disable Autoconfig Settings 
Removes the ability to adjust the Auto configuration settings 
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Disable Proxy Settings 
Turns off the ability to adjust the Proxy Server Settings. Ideal if you wish to force the use of a proxy server on 
the browser. 
Disable Advanced Tab 
Removes the Advanced Tab from the IE Control Panel 
 
Hide Advanced 
Remove the advanced button from the Proxy Settings Section IE Control Panel 
 
Hide Security 
Remove the Security section from the IE Control Panel 
 
Disable Security Change 
Turns off the ability to change security settings 
 
Disable Security Add Sites 
Turns off the ability to add Web Sites to the different security zones 
 
Hide Programs 
Hides the programs tab of the IE Control Panel 
 
Disable Calender Contact 
Remove the Calender Contact section from the IE Control Panel 
 
Disable Messaging 
Turns of the messaging features of IE 
 
Disable Reset Web Settings 
Turns off the ability to reset any changes to IE back to the default settings 
 
Disable Check if Default Browser 
Stops IE checking to see if it was the default brower 
 
Disable Microsoft Wallet Settings 
Turn of the settings for the Microsoft Wallet 
 
Disable Privacy Tab 
Hides the Privacy Tab 
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Network and Security 
 
Persistent Network Mappings 
Remember any Network Mappings in Network 
Neighbourhood.  
 
Hide Entire Network in Network 
Neighbourhood 
Hides the Entire Network in Network 
Neighbourhood, thus only allowing you to see 
your own workgroup 
 
Hide Network Connect and Disconnect in Explorer 
Prevents users from making additional network connections by removing the Map Network Drive and 
Disconnect Network Drive buttons from the toolbar in Explorer and also removing them from the Context 
menu of My Computer and the Tools menu of Explorer. 
 
Disable General Password Caching 
This turns off general password caching, like the passwords used for shares and so forth. This enforces internal 
security by making people type in share passwords when required. 
 
Do not Display Last Logon Name (NT/2000) 
Selecting this will mean that when windows logs on, it will not show the user name of the last person to 
successfully log on in the log on dialog 
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Other Features 
 
Automatically Log into Windows 
This will allow windows 2000 and XP to 
automatically log a single user in 
 
Force the Use of Automatic Logon 
Normally when a Windows machine is configured 
to automatically logon to a specified account users 
can bypass this and enter alternate account 
information. This tweak forces the machine to auto 
logon and to ignore any bypass attempts. 
 
Disable Automatic Logon Shift Override Feature 
When using the automatic login feature it is possible for a user to hold the Shift key to bypass the login 
sequence and enter a username and password. This feature disables the ability to override the function. 
 
Default Download Directory 
This allows you to choose the default download directory for Internet Explorer 
 
Disable File Download in Internet Explorer 
Turns off the ability to download files in Internet Explorer. Only web pages, and pictures will be downloaded. 
 
Click to confirm all saved settings 
This is a reminder function especially to save the manually entered information like user name and password. 

Refresh Security Features 
Clicking this button will allow you to recheck security features as it rereads the registry looking for appropriate 
values for the security panel display. 
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